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Pre-requisites 

Saving work 

Have a clear idea about where pupils should save their work. The lessons assume that pupils know 
about folders and files on whichever network they are using. If they do not, it might be worth 
spending some time teaching about files and folders and the difference between saving in the 
cloud, saving on the school server or saving on the device itself where any of these methods are 
used within your setting. It would be useful for pupils to know how to create folders so that they 
can organise their files if they have the security rights to do this. These skills are not used much 
within the lesson plans but will be important for pupil’s ongoing work with the files that they 
produce. 

Printing 

Pupils will not be routinely required to print during these lessons though lesson 8 does include 
considerations when printing. So, it is useful to have a connected printer available. 

Mathematics skills 

Pupils will be using their maths knowledge when working with spreadsheets in some lessons as 
spreadsheets have many mathematical applications. Pupils who struggle with maths might need 
additional support, however, the focus should be on support in using spreadsheets for the most 
part. In lesson 5, pupils will use averages, minimum and maximum values so familiarity with this in 
maths is useful. 

Vocabulary 

Pupils will be introduced to the following terms: 
Alignment Format Row 
Area Formula(e) Spreadsheet 
Calculate  Function Style 
Cell Graph Sum 
Cell reference Graphics Table 
Chart Model Text Wrapping 
Column Open Value 
Data Range Workbook 
Effects Reference  
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Medium-Term Plan 
 
Lesson  Title Success Criteria 

1 What is a spreadsheet? 
• Pupils know some uses of a spreadsheet tool. 
• Pupils can navigate around a spreadsheet using 

cell references. 
• Pupils can enter data into cells. 
• Pupils understand new vocabulary relating to 

spreadsheets: cells, columns, rows, cell names, 
sheets, workbook. 

2 Basic calculations 
• Pupils can use a spreadsheet to carry out basic 

calculations including addition, subtraction, 
multiplication and division formulae. 

• Pupils can use the series fill function. 
• Pupils recognise how using formulae allows the 

data to change and the calculations to update 
automatically. 

3 Modelling 
• Pupils can use a spreadsheet to model a situation. 
• Pupils can use a spreadsheet to solve a problem. 
• Pupils can use the SUM function 

4 Organising data 
• Pupils can use a variety of methods including flash 

fill, convert text to tables and splitting cells for 
organising and presenting their data in a 
spreadsheet. 

• Pupils know what is meant by a delimiter. 

• Pupils understand how to sort data. 

5 Advanced Formulae and Big 
Data 

• Pupils know how to incorporate formulae for 
percentages, averages, max and min into their 
spreadsheets. 

• Pupils gain familiarity with range notation. 



Purple Mash Computing Scheme of Work – Unit 6.9 Spreadsheets (with Google Sheets) 
Medium Term Plan  

Need more support? Contact us:  

Tel: +44(0)208 203 1781 | Email: support@2simple.com | Twitter: @2simplesoftware 

6 

• Pupils know some shortcuts that help to make 
data meaningful. 

• Pupils begin to develop a critical eye when it 
comes to the conclusions that can be made from 
data. 

6 Charts and Graphics 
• Pupils know that there are ways to represent their 

data graphically and that spreadsheets can make 
the process of representing data easier. 

• Pupils gain an understanding of how a graphical 
representation can make data easier to interpret. 

• Pupils make a variety of charts using Sheets. 
• Pupils illustrate their data using sparklines and 

data bars. 

7 Using a Spreadsheet to plan 
a cake sale 

• Pupils can understand how a spreadsheet can be 
used to plan an event. 

• Pupils understand the advantages of using 
formulae when data is subject to change. 

• Pupils have modelled a real-life situation using a 
spreadsheet. 

8 Using a spreadsheet to solve 
problems 

• To apply all new spreadsheet skills to solving 
problems and presenting data. 

• To explore printing spreadsheets. 
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Lesson 1 – What is a spreadsheet? 

Learning Objectives: 

• To know what a spreadsheet looks like. 
• To navigate and enter data into cells. 

Success Criteria: 

• Pupils know some uses of a spreadsheet tool. 
• Pupils can navigate around a spreadsheet using cell references. 
• Pupils can enter data into cells. 
• Pupils understand new vocabulary relating to spreadsheets: cells, columns, rows, cell 

names, sheets, workbook. 

Resources: 

• Pupil Spreadsheet. This workbook contains examples that pupils will use in several lessons. 
These are in different sheets labelled by lesson number. Each pupil will need a copy of this to 
edit. Save the file somewhere accessible to all but ensure that each pupil saves their own copy 
before editing. 

• Solutions and teacher demonstration spreadsheets are provided in Teacher Spreadsheet 
Examples. 

NB Depending upon your display settings, the row heights of the rows in the 
example files might get compressed, you can drag the rows taller if you need to:  

Activities: 

1. Explain that Spreadsheets are a software tool used for organising information. For example, if 
you were planning a tea party you could enter into the spreadsheet all the things you will 
need to get for the party and who you were going to invite. Can they think of any other things 
that could be stored in a spreadsheet for organising a party? (menus, gift list, entertainments). 

2. Many people make lists on paper but the advantage of using a spreadsheet is that it can also 
do calculations for you. Explain what this means e.g. you could enter the cost of the different 
things that you will need for your party into the spreadsheet and then easily calculate how 
much money you will need to buy them all. If pupils have used 2Calculate, much of this will be 
familiar to them. 
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3. Sheets is a more complex version of 2Calculate, it does not have some of the tools that are 
used in 2Calculate, but it has other different tools. 

4. Open Sheets and look at the front screen, if you are using the tablet app, the screen will be 
different but you should be able to identify the same features (templates can be located in the 

app by clicking on the symbol on the bottom right). Point out the following sections to 
pupils: 

5. Click on the blank document button to open a blank page. 
6. First look at the menus at the top. Point out the following locations and the words used to 

describe them. If pupils are familiar with the vocabulary, it will make the teaching easier. NB 

The app version has an icon bar but not a menu bar. Menu options are available in the top 
right by clicking on the three horizontal dots. 

7. When you hover your mouse over any of the icons, you see a tooltip appear, this is to help you 
understand what the icon does. Can pupils identify the icons for…: 

• Undo 
• Zoom 
• Font type and size 
• Shading cells 
• Formatting data 
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8. Clicking on any of the menu bar choices will open more menu choices. Can pupils find where 
to click to: 

• Copy data 
• Make a copy of a sheet 
• Insert an image 

9. Next look at the bottom of the screen. Point out that the main part of the page is known as a 
spreadsheet. When you save a file, it can contain more than one sheet. The sheets tab shows 
how many sheets are in the file. The example below has three sheets. The sheet called Sheet3 
is currently selected. The complete file is called a spreadsheet workbook 

10. Show how to zoom in and out using the zoom control . On a tablet, you zoom using a 
two-finger gesture, show pupils how to do this if they do not know. 

11. Can pupils identify what this file is called? 
12. You can see the name on the top left. It is currently called ‘Untitled spreadsheet’. Click on the 

name and rename it to something sensible such as ‘Lesson 1’ even though it does not contain 
any contents yet. Google will automatically save your changes. 

13. Now look at the main part of the page; the spreadsheet itself. 

14. Spend some time showing pupils the following things, emphasising the new vocabulary in 
bold: 
• The rows: These are numbered. 
• The columns: These are labelled using letters. 
• The word cell is used to describe each box in a spreadsheet. 
• Each cell has a cell reference that shows its position. In the example above, cell C4 is 

selected. Click on some cells and demonstrate that the column and row labels get 
highlighted to help you name them. 

• Each cell can contain words, numbers or calculations. 
• Cells can be formatted in the same way that text can be formatted in a word processor 

document. Identify the icons to do this. 
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15. Show pupils the following methods of navigating from cell to cell (navigation methods will 
vary if you are using the tablet version), check the version that pupils will use and 
demonstrate this version: 
Desktop version: Click on a cell and enter a number, click the enter key to move to the cell 
below. Do this a few times and then click shift + enter. This moves to the cell above. Notice 
that typing will replace the cell contents. 
Desktop version: Click on a cell, enter a number and press the tab key to move to the cell to 
the right. Do this a few times and then press shift +tab to move to the cell to the left.  Notice 
that typing will replace the cell contents. 
Tablet app: The enter key will navigate downwards. There is no shift enter option. 
Tablet app: There is no tab option. 

16. To delete the contents of a cell, use either the backspace key or the Delete key. 
17. Instruct pupils how to open the file for this lesson and navigate to the first tab. Explain that 

they will be using different tabs of the same workbook in each lesson.  
18. In this week’s lesson, pupils need to work out the sentences using the cell references. If they 

click in a blank cell and type ‘=’ and the relevant cell reference number e.g. =E23, the content 
from that cell will be inserted; this is a quicker method than simply typing the words. 

19. Before beginning work, explain that in Sheets, to edit cell contents without replacing what is 
there, you need to do one of the following: 

• Double-click on the cell and then a cursor will appear to edit the contents. 
• Click on a cell and then edit the contents in the bar at the top of the sheet 

20. Pupils who finish should save their work and then open a new workbook (new file). They can 
create their own puzzles for the rest of the class to try. 
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Lesson 2 – Basic Calculations 

Learning Objectives: 

• To introduce some basic data formulae in Sheets. 
• To demonstrate how the use of Sheets can save time and effort when performing 

calculations. 

Success Criteria: 

• Pupils can use a spreadsheet to carry out basic calculations including addition, subtraction, 
multiplication and division formulae. 

• Pupils can use the series fill function. 
Pupils recognise how using formulae allows the data to change and the calculations to 
update automatically. 

Resources: 

• Pupil and Teacher workbooks as previous lesson. 

Activities: 

1. Recap pupil understanding of what a spreadsheet is using the information from lesson 1. 
Explain that today, pupils will explore the ability in Sheets for carrying out calculations quickly. 

2. The way that Sheets does this is by using something called formulae. Introduce the words 
formula and formulae. 

3. Explain that this sounds complicated, but you already use formulae all the time.  If I were to 
ask you a question; Petra had 67p and bought a book for 43p, how much would she have left? 
You would use a formula to work this out. What would the formula be? 
Answer: Petra’s money, take-away cost of book equals amount left. 
A formula is a way of writing a calculation in a general way. 

4. Open a blank spreadsheet and enter any number in cell A1 and another number in cell B1. 
Pupils could do the same as you demonstrate. 

5. Click in cell C1 and explain that you want this to equal the sum of whatever is in cells A1 and 
B1. 

6. Press the equals key (=) to tell Sheets that you are entering a formula. 

A formula is a group of letters, numbers, or other symbols which represents a scientific or 
mathematical rule. 

Collins Dictionary, https://www.collinsdictionary.com/ 

https://www.collinsdictionary.com/
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7. Click on cell A1 or type ‘A1’. 
8. Type the operator (+) 
9. Click on cell B1 or type ‘B1’. 
10. Direct pupil attention to the formula bar at the 

top of the spreadsheet, this can be a useful place 
to view and edit your formulae. 

11.  Press the enter key. The cell should now display 
the answer to the calculation. 

12. Change one of the numbers in cell A1 or B1 and note how the answer updates. 
13. Click in the formula bar and change the operator to *. Ensure that pupils understand that * is 

the way to write a multiplication symbol on a computer. Ensure that they know how to type 
the * e.g. using shift + 8 keys. 

14. Note that the number in cell C1 has updated to the correct answer. 
15. Discuss the operators – and /. 
16. Explore the effect of changing the formula to use these operators. You could pose some 

calculations for pupils to adapt their formulae and cell content to. 
17. Open the example spreadsheet and direct attention to sheet Lesson 2. 
18. Pupils need to add the correct formulas. The sheet is self-marking, so the aim is to get 20 out 

of 20. 
19. Once pupils have completed the formulae, they should try changing the numbers in columns B 

and D and verify that the score remains the same. This helps pupils to verify that they have 
used formulae rather than calculating the answers and typing them in. 

20. Once most pupils have finished, bring the class back together and open the files used at the 
beginning of the session on the whiteboard. Add some more numbers to columns A and B: 

21. Click on cell C1 and verify that the formula is still there. 
On a laptop or PC: Move the mouse to the bottom right-hand corner of the cell where there is 

a small square. The cursor should change to + 

Hold down the mouse button and drag to the other cells in column C where there are 
numbers in columns A and B. Lift the mouse button. 
On a tablet: perform a short tap on cell C1 and choose ‘copy’. Click on cell C2 and drag the 
blue circle on the bottom right and drag to the other cells in column C where there are 
numbers in columns A and B. On the menu that pops up, click ‘Paste’. 
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22. Column C should now contain the sum of columns A and B*. Click 
on one of these cells and look at the formula. Sheets can create 
the formulae for you. Note that the calculations will all be the 
same operator. 

*Right-clicking on the cells, then selecting Paste Special, controls 
how the cells are filled. You might need to change this if the 
formulae do not appear.  

23. Turn your attention to the bottom cell with numbers in column A. Enter some numbers in this 
column in numerical order and then drag the mouse over them to select them: 

24. Move the mouse cursor to the square on the bottom right as you did previously. Drag down a 

few rows. This should automatically fill a series of numbers: 

25. Delete the numbers in column B and then type in cells B1, B2 and B3 the first three numbers 
of the 5 times table. 

26. Highlight cells B1, B2 and B3 and drag column B down as you did for column A. It should fill 
in with numbers from the five times table.  Then drag column C down. Show pupils how easy 
it can be to complete calculations in a spreadsheet. 
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27. Scroll down to row 35 of the Example spreadsheet. Show pupils that they should use the 
same method to fill the columns as requested and see how long it takes them to complete this 
task. Note: The score here starts at 19 out of 20 because most of the cells are empty (=0). 
This will change as pupils fill them in. They should try to end up with 20 out of 20. 

28. Save the work and then reflect upon how long this would take to do by hand even if you had 
a calculator. 
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Lesson 3 – Modelling 

Learning Objectives: 

• To use a spreadsheet to model a situation. 

Success Criteria: 

• Pupils can use a spreadsheet to model a situation. 
• Pupils can use a spreadsheet to solve a problem. 
• Pupils can use the SUM function 

Resources: 

• Workbooks as previous lessons. 

Activities: 

1. Remind pupils that in the last lesson, they learnt how to use formulae in spreadsheets. Today 
they will be making use of these skills using a spreadsheet that models a real-world situation. 

2. The theme is planning a birthday party and making sure that you can afford the party. 
3. Show the class the party planner spreadsheet (Lesson 3 - Planner). The spreadsheet is 

designed to help you plan a party. Google sheets has built-in templates that you can use and 
adapt for your purposes. We will not be using all the functions of this spreadsheet, but it is a 
good illustration of the kind of tool that you can make with Sheets. 

4. This sheet has some built in formulae already that will update for you. Click on cell T43. Note, 
this sheet contains places where several cells have been merged into one, this is to make the 
layout look good. T43 is one of these cells. 

5. What does the number in this cell represent? 
Answer: It is the cost of the party. 

6. Look at the formula in the cell. It is not something that pupils have encountered before. 

This means that the contents of the cell equal the sum of cells O41 to O47. 
7. Find cell O41 and O47, highlight these cells to show this range to the pupils. There is an error 

here, can they spot it? 
Answer: The cost of the venue is not included. 

=SUM(O41:O47) 
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8. Take suggestions about how to change the formula to include the venue code and make the 
changes to the formula so it now reads ‘=SUM(O40:O47)’. See the updated total. 

9. Click on cell T46, what does this show? Is the formula correct? (Yes, it is). 
10. Change the budget for the party to £500 (cell T40) and notice how the Difference in cell T46 

changes, what does this show? 
11. Click on the following cells to explain where the numbers come from. There are some errors 

that pupils will be correcting on their own spreadsheets. 

• O40 (and other category totals) 
• P50 – this adds up all the venue expenses (though it currently contains an error). 
• P64, P74, P86, P96, P102, P112, P121 
• C40 to C47 – this demonstrates how text can also be copied using a formula. Try changing 

cell C64 to ‘Decorations’ and then look at the impact on cell C41 and on the key to the pie 
chart. 

12. Notice that the cells with prices are all formatted as currency. Demonstrate how to do this on a 
blank sheet. First enter some numbers and then highlight them. Show pupils that you can 

highlight a whole column by clicking on the heading at the top. 
13. Click on for Format in the menu bar. Then select Number → Currency. 

NB If you find that the currency displayed is incorrect for your location: Click File → 
Spreadsheet settings. Change the settings here. 

Alternatively, click on the  icon and then Currency. 

On a tablet click the format icon then select Cell →Number format → Currency (if correct) 
or More currency formats (select correct one e.g. British pound). 



Purple Mash Computing Scheme of Work – Unit 6.9 Spreadsheets (with Google Sheets) 
Lesson 3 

Need more support? Contact us:  

Tel: +44(0)208 203 1781 | Email: support@2simple.com | Twitter: @2simplesoftware 

17 

14. Have a brief look at some of the other available formats as well as the related icons:  

15. Return to the party spreadsheet and make a big change in the venue costs for example 
change the cost of the hall to £300. Show pupils how the pie chart updates automatically. 
These sorts of tools have many very useful applications and ways to be able to interpret data 
clearly. 

16. Switch to sheet 3 (Prices). This is where pupils will work out the prices that they will put into 
sheet 3a. 

17. For the sake of simplicity, the following categories are priced by party (rather than depending 
upon the number of guests): Venue, Décor, Entertainment, Invitations, Other. 

18. This means that pupils need to decide which items to have at their party and add them to the 
planning sheet in the correct category along with the cost. There is space for pupils to add 
additional choices and prices if they wish. 

19. Food, Drink and Going Home gifts items are priced per guest. Show pupils these on the prices 
sheet (rows 53 and down). Pupils need to put in the number of guests who will have each 
item then use a formula to calculate the totals. They can then put these into the planner sheet. 
Some pupils will be able to use a SUM formula to calculate the total cost, though they do not 
need to put this on the pricing sheet. 

20. Display the Lesson 3 Prompt Sheet. This is on sheet: Lesson 3 (Prompts). Pupils can use this 
to guide their work on their spreadsheets. They can shade the cells in column B to show 
which steps they have completed. 

21. Once pupils have finished, ask some questions that pupils can use their spreadsheets to 
calculate the answers to: 
• What does the pie chart show? 
• What is the overall cost? 
• Set a budget lower than the average amount that pupils have budgeted for, ask pupils to 

revise their party to fit the new budget? 
• Can they reflect upon how it was easier to do this using their spreadsheet than if they 

had lists on paper or in a work document? 
22. If there is time left, pupils could explore some of the other in-built templates in Sheets; these 

cover a wide variety of uses. 
 

At this point, you might wish to draw pupils’ attention to the number of decimal places 
option if this is something that pupils have covered in maths. 
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Lesson 4 – Organising data 
NOTE: The functionality used in this lesson is only available in the full version of Sheets not in 
the tablet app. Features of this lesson that can be achieved on the tablet are detailed at the end 
of the lesson plan so that they can be taught discretely. 

Learning Objectives: 

• To demonstrate how spreadsheets can make complex data clearer by manipulating the way it 
is presented. 

Success Criteria: 

• Pupils can use a variety of methods including flash fill, convert text to tables and splitting cells 
for organising and presenting their data in a spreadsheet. 

• Pupils know what is meant by a delimiter. 

• Pupils understand how to sort data. 

Resources: 

• Workbooks as previous lessons. 

Activities: 

1. Display sheet Lesson 4 (teacher demo). Explain that another teacher passed on some 
information about the planets in the solar system and wanted you to make a spreadsheet of 
them. However, she typed it in a word processor and sent it over. 

2. Now, it is hard to see the sheet properly as the data looks like it is in multiple columns. Column 
A width is too small and because there is no data in column B, the text overflows. Show 
pupils how to change this using Autofit. You can autofit the width by double clicking on the 
cell boundary when the arrow looks like this  
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3. Next, let us make a space for a heading. 
To insert rows, choose one of these options: 

• Right-click on the left-hand side of row 1 (in the grey box that says 1). This will select it 
and a menu will pop-up. Click Insert 1 above on this menu.  

• Select the row and then in the menu bar, click Insert → Row above. 

• On a tablet, select the row and then in the icon bar, click . 
4. Type the title ‘Lesson 4’ in the top row and format it if you wish. 
5. Insert another row to contain headers for the columns. The headers should be: 

• Planet Name 
• Distance from the sun (km) 
• Diameter(km) 
• Number of Moons 
• Has Rings 
• Length of year (in Earth days) 
• Composition 

6. Start typing the names of the planets below this. Look out for the following: 

7. Try to do this for the next data which is Distance from the sun, and you will find it does not 
work so well. This is because Sheets cannot find a pattern to use. For this we need to split 
the column based on something called delimiters. 

8. A delimiter is a character that separates each piece of data. Ask pupils to have a look at the 
example data and identify the delimiters that are used. 
Answer: spaces, semi-colons (;) and dashes (-).  

9. Select the data in cells A3:A10 (the un-organised data), then in the Data menu find Split 
text to columns. NB If at any time you ‘lose’ the delimiter box, select the data and click 
Data → Split text to columns again; making use of the undo button if you need to. 

As the first letter of Mars was typed, the 
end of the name filled automatically. The 
column is filled with the rest of the planet 
names in light green. 
Click the tick and the names will fill for you. 
This is called flash fill. 
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10. Initially, Sheets will try to split the data for you. Sometimes this will work but not in this 
case: 

 
11. Click on the small arrow next to Detect automatically and you are offered some choices: 

12. Tick on the delimiter ‘Space’ and look at what this would do to the data. It separates the 
planet names. But it also separates all the notes on the planet composition and some of the 

other data is still lumped together. Untick the ‘Space’ tickbox. 
13. What delimiter can separate the distance from the sun and diameter? 

Answer: a dash (-). 
14. Notice that dash is not given as an option for a delimiter. What you need to do is tick the 

Custom box and then enter a dash in the box next to it: 

 
15. Look at the data: 
16. This separates the Distance from Diameter and there is no data separated that should not 

be. We can separate the other data later. Click Next. 
17. Size columns B and C as you did before.  
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18. Look at the data, you will still need to separate the remaining data in column A, what 
delimiter can be used for this? Answer: a space.  

19. Before selecting the data, insert a new column after column A. This is so you can put the 
separated data here and not overwrite the other data. Now select the data in column A and 
go through the Data → Split text to columns process again asking the pupils to guide you. 
The delimiter should be space. Size the column width and check that the data looks right.  

20. Look at the remaining data in column G, what delimiter can be used to separate the 
Composition from the rest of the data? Answer: semi-colon (;). 

21. Cut and Paste the Headers to the right places. 
22. Look at the pupil sheet for Lesson 4, pupils need to follow a similar process with data. They 

will be separating different sets of data by one or two delimiters only to make things less 
complex except in the challenge task. There is a reminder on the sheet of the tasks to do. 

23. Once most pupils have finished or nearly finished. Bring the class back together to look at 
sorting data. Demonstrate using the sheet Lesson 4 (Sorthing example). This data is the 
same as the challenge task answers. 

24. See whether pupils know what sorting data means and why it might be done? Have they 
ever done a search on a shopping website and then sorted the results by the price to see 
what they could afford? Or by the highest customer rating? How is the daily school register 
sorted? 

25. Let us see how Lucy could sort her data by her friend’s surnames (like the school register). 
26. Click on any of the cells in the surname column (column B).  
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27. Click Data in the menu bar. To bring up these options 

28. Click on the first option (Sort sheet by column B). 
29. Look at the data now, has this worked? Answer: It has but it has also sorted the header 

row in with the data. 
30. Click undo 
31. This time, select the whole sheet by clicking in the top left of the sheet:  

32. Click Data → Sort range to open the following screen: 

33. If you tick the box to say you have header rows, you will then be able to choose to sort by 
any of the headers. Choose Last name. 
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34. Do any of the friends in the data have the same surname? Yes (Aluminium and Lithium). 
How should Sheets order names when the surname is the same? Pupils might suggest 
First name (or you can try the options e.g. birthday. Though the Lithium sisters have the 
same birthday as well. 

35. Repeat the steps to sort a range and this time click on the button ‘Add another sort 
column’. Choose the data that pupils decided upon. 

36. Ask pupils how to sort the data by birthday? They will have to format the cells with 
birthdays as dates first. 

37. How could this be useful? Perhaps it would help Lucy plan who she needs to buy presents 
and cards for over the year? 

38. Another useful thing that you can do is highlight the data and click Data → Create a filter. 
This adds small arrows that you can use to sort by one column. 

39. Pupils can open the sheet Lesson 4 (Minibeasts) and add filtering to the data. See whether 
they are able to answer sorting and filtering questions such as how many minibeasts have 
a water habitat? Which minibeast has the most legs? 
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Skills for tablet and online version users that are 
taught in lesson 4 

Fitting Columns 

Look at the data on the sheet for lesson 4. It is hard to see the sheet properly as the data looks like 
it is in multiple columns. Column A width is too small and because there is no data in column B, 
the text overflows. Show pupils how to change this. 
Select the whole column by clicking in the title box and then autofit the width by double clicking 
on the cell boundary where you see this icon  

Space for Headings 

To insert rows at the top, select the top row and then in the icon bar, click . 

Sorting Data 

(Demonstrate using the sheet Lesson 4 (Sorting example). 
1. See whether pupils know what sorting data means and why it might be done? Have they 

ever done a search on a shopping website and then sorted the results by the price to see 
what they could afford? Or by the highest customer rating? How is the daily school register 
sorted? 

2. Let us see how Lucy could sort her data by her friend’s surnames (like the school register). 
3. Click on any of the headers. 
4. Click the three dots in the top right. 
5. Click ‘Create a filter’. 
6. This adds small arrows that you can use to sort and filter. 
7. Demonstrate using these to sort by Last name. 
8. Demonstrate filtering all those who do have chat messaging: To do this press on the filter for 

the chat column, choose filet by condition→ Text contains → type ‘y’ and then click the tick 
in the top left. 
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9. Pupils can open the sheet Lesson 4 (Minibeasts) and add filtering to the data. See whether 
they can answer sorting and filtering questions such as how many minibeasts have a water 
habitat? Which minibeast has the most legs? 
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Lesson 5 – Advanced Formulae and Big 
Data 

Learning Objectives: 

• To use formulae for percentages, averages, max and min into their spreadsheets. 

Success Criteria: 

• Pupils know how to incorporate formulae for percentages, averages, max and min into 
their spreadsheets. 

• Pupils gain familiarity with range notation. 
• Pupils know some shortcuts that help to make data meaningful. 
• Pupils begin to develop a critical eye when it comes to the conclusions that can be made 

from data. 

Resources: 

• Workbooks as previous lessons. 

Activities: 

1. Open the example file to the Lesson 5 sheet. This sheet contains data about pupils results 
on a times table testing app. The test was out of 25. Pupils took the test 6 times: 
September was before they had used the Monster Multiplication app to practise and then 
at further points during the school year. 

2. What can they tell from looking just at the data overall? Answer: not much! 
3. We are going to find out about ways that a spreadsheet can make data useful. 
4. On the sheet look at the textbox that says ‘Level 1’. These are tasks that the pupils should 

be able to do to make the data look better. Go through the instructions in the textbox and 
demonstrate if you feel it will be necessary. Let pupils try this with their data. Remind them 
about the undo button in case things go wrong. 

5. Bring the class back together when they have completed Level 1. Some pupils might like to 
start on level 2 themselves if they are waiting.  
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6. Look at the tasks in Level 2 together: 
7. Level 2 involves calculations. Add a column called Totals in column J (the text boxes can be 

dragged out of the way). Pupils who have already started will have typed this in and it will 
have followed the formatting automatically. Others can do this now. 

8. Insert a formula that adds up each pupil’s score in this column. To do this click in cell J2 and 
type =SUM(D2:I2). Ask pupils to explain what this means. Sheets might suggest the 
correct formula for you, in which case you can press enter as suggested. 

 
9. Can pupils remember how to copy this formula to the other rows by dragging the small 

blue square? NB On a tablet you need to drag and then tap on the selected cells and 
choose AutoFill.  

10. Does the total score tell us very much about how the pupil is doing? It does not really. Is 
there something better that could measure this? Hopefully, pupils will suggest the average 
score as a possibility. 

11. Click undo a few times to get rid of the totals or delete the contents of the cells. 
12. Next actions depend upon device so follow those for the device that pupils are using. 

 



Purple Mash Computing Scheme of Work – Unit 6.9 Spreadsheets - – Lesson 5 
With Google Sheets 

Need more support? Contact us:  

Tel: +44(0)208 203 1781 | Email: support@2simple.com | Twitter: @2simplesoftware 

28 

On PC:  
• Click in cell J2 then on Insert in the menubar. 
• Select Function. 
• Select AVERAGE. 
• Drag to highlight cells D2:I2 (or type this in the 

formula). 
• Press enter. 
• Drag as before to copy the formula to all of the 

rows. 
On tablet:   

• Click in cell J2 and type ‘=’ in the cell. 
• In the formula bar at the bottom, begin to type Average – the word should pop-up 

just below. 
• Tap on the word average. 
• Type D2:I2 in the brackets. 

• Press enter. 
• Drag as before to copy the formula to all of the rows. 

13. Add additonal columns called minimum and maximum. Show pupils that they can use the 
in-built functions (MIN and MAX) to calculate these as well. What do they show? 

14. Ask pupils to complete Level 3 (even if they didn’t do level 2). 
15. Check that pupils could sort to find the pupils with the highest overall average. 
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16. Ask pupils to filter for the pupils scoring below 10.  To do this, they will need to click on the 
filter for Pupil average score. Then look for Filter by condition as follows: 

17. look at the bottom right for the following box (On tablets, the data should be displayed 
along the bottom): 

Click on the small arrow and change this to Count: There should be 11 pupils. 
18. Remind pupils how to remove the filter; by setting the Filter by Condition to None. 
19. Level 4 includes a variety of tasks that help to analyse the data. Not all pupils will have time 

to complete all tasks.  If pupils are using tablets, they will not be able to do step 5-8 so this 
could be demonstrated with pupils on the board. Ensure that there is time to complete the 
steps below even if children have not finished Level 4. There are some questions posed 
which pupils can answer by clicking on the text drawings and editing then saving. 
NB If the boxes with the tasks disappear, this might be because of the filtering. Clear the 
filter and they should reappear. If pupils are getting confused, show them that the tasks 
are repeated on the next sheet of the workbook as well and they could use this. 

20. The final question asks pupils to investigate the scores of the different classes, they will 
find that one class appears to be doing much better.  

21. Filter by each class in turn, select that class’ data for September and look at the bottom 
right for the following box: 

22. Click on the small arrow and change this to average. This is the average starting score for 
this class. Fill this information in on the table in row 100. Ask pupils to use their data to 
give you the numbers for the other classes and for the July scores  

23. Look at the Difference column; what is this calculating? What we can conclude from this? 
Discuss the following as a class: 
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• Does the data tell you whether this is due to a bad teacher, poorly behaved pupils 
who do not practice, a cheating teacher, pupils who don't have access to the 
computers as much? 

24.  It is useful to relate this to fake news considerations; people can draw all sorts of 
conclusions from data but often they are not things that can be accurately worked out from 
the data alone. Having a good understanding of data can protect you from getting sucked 
into fake news reporting when reporters attempt to use data to confuse you into their way 
of thinking. 
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Lesson 6 – Charts and Graphics 

Learning Objectives: 

• To create a variety of charts and graphs to understand data. 

Success Criteria: 

• Pupils know that there are ways to represent their data graphically and that spreadsheets 
can make the process of representing data easier. 

• Pupils gain an understanding of how a graphical representation can make data easier to 
interpret. 

• Pupils make a variety of charts using Sheets. 
• Pupils illustrate their data using sparklines and data bars. 

Resources: 

• Workbooks as previous lessons. 

Note: The lesson plan includes demonstrating a variety of techniques before pupils try these 
on their own spreadsheet at the end. If you prefer, break the lesson up by asking children to 
complete parts of their own spreadsheet at the suggested stages see the * 

Activities: 

1. Explain that today, pupils will be making some graphs and charts using a spreadsheet. In 
Sheets, the x-axis of a graph is called the horizontal axis. The y-axis is called the vertical axis. 

2. Either axis can hold: 
• Numerical values such as pounds, hours, time, temperature. This is called a value axis. 
• Categories such as dates, names, products, subjects. This is called a category axis. 
3. Pie Chart 
Display the first table of data in the example spreadsheet. Can pupils interpret what the data is 

about? 
4. Select the data and choose Insert → Chart. Sheets will generate a pie chart automatically.  
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5. You can then change aspects of the chart by clicking on them and looking on the right-
hand side. These aspects are categorised as follows (in the Customize tab). Choices are 
more limited in the tablet version: 

6. Experiment with changing the title and the colour of one of the slices along with other 
options including: 
• (Non-tablet) Click on one of the slices → Pie slice → change the Distance from center. 

Why might you want a chart like this? Possibly to emphasise one particular slice. 
• Pie chart → Slice Label; explore the effect of changing this. 
• Legend → Explore the effect of changing this. *This fits with level 1 of the pupil 

exercise. 
7. Bar chart 

Still on the pie chart, click on Setup on the right-hand side panel. 
Click on the Chart type drop-down and select a column chart or a bar chart. 
Explore options as before. 

8. Switch to the next data table. This shows profits over three months for some fictional 
supermarkets. 

9. Select the data (except for the Profits heading) and click Insert→ Chart. Sheets creates a 
Stacked column chart. Help pupils to understand what this is showing. Show how the 
height of the columns shows how some supermarkets are making more profit than others. 
The colour denotes which month the profit was made in. *This fits with level 2, task 1 of 
the pupil exercise. 

10. Change the chart type to a 100% stacked column chart; this can be found by looking in 
the chart type drop down on the right-hand side and hovering your mouse over the type of 
column charts. 

11. Explain that in this type of chart you cannot compare the profits of each supermarket 
against each other, but you can compare the proportion of profits that they made in each 
month. You can see that Frescos makes a disproportional profit in Jun; perhaps they had a 
special promotion that really helped sales. Stainsbury had a good profit in which month? 
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12. Sparklines 
Sheets can also create graphical elements that are part of the data tables like mini graphs 
on each line of the spreadsheet that help you to understand the data. 

13. Click in cell F19 and go to Insert → Function →All → Sparkline (alternatively, type 
‘=SPARKLINE(. 

14. Select cells C19:E19, then press enter. The formula should be ‘=SPARKLINE(C19:E19)’. 
15. Drag this cell to the others below it. You will get a visual representation of the 

supermarkets’ profits over the three months. 
16. Try this with the next table as well. This one shows shop sales from different products. 
*This fits with level 2, task 2 and level 3 of the pupil exercise. 
17. Line graphs 
Look at the next data table. Can pupils work out what this shows? What type of graph might 
be best for this sort of progressive data over time? 
18. Select the data and insert a chart. You might find that Sheets selects a combo chart for 

this, but a line chart would be better, remind pupils how to change the Chart type. 
19.  The vertical axis seems to cut off part of the graph at the top: 

 
20. To fix this, click on the Customize tab in the chart editor on the right. Look for Vertical axis 

and expand the options for this. Set the Max value for this axis to something greater than 
the maximum temperature:  

21. Explain that having a pretty graph is of no use unless it tells the reader something. What 
can you tell from the temperature graph? How do the temperatures differ indoors and 
outdoors? Can you think or reasons for the variations? *This fits with level 4 of the pupil 
exercise. 
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22. NB You cannot create the color scales in this step on a tablet. Look at the last set of data. 
There is a lot of data here. Click Insert →Chart. You get a very concentrated chart. Is it easy 
to understand this data? Answer: Not really. There is too much data to visualise it easily. 

23. Highlight the temperature data: Cells  D71:O132. 
24. Click Format → Conditional formatting. 
25. On the right-hand side, choos ethe Color scale tab. This should make the data immediately 

clearer. 
26. To improve this even further, turn your attention to the options displayed for colours in the 

Format rules: 

27. Click on the paint pot for the min and max value and change the colours to cold and hot 
colours e.g. ice blue and bright red. 
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28. Click the drop-down for Midpoint and select Number. Then choose a mid-temparature 
colour such as an earthy green. Pupils should be able to see that this makes the data much 
easier to understand than the graph: 

29. .Direct pupils’ attention to the Lesson 6 sheet of the pupil file. This has six different sets of 
data to format, putting into practice things that have been demonstrated. Pupils who are 
using a tablet will not be able to complete all of the suggestions. They can still use the 
examples to format the data to make it more readable. 

30. Give pupils time to put these skills into practice. 
31. Finish the lesson with a discussion of the point of displaying data in a graphical way. Can 

pupils make a list of positives and negatives? The aim is to help pupils start to discern what 
graphics are appropriate and which can actually misrepresent data or make it confusing. 
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Lesson 7 – Using a Spreadsheet to plan 
a cake sale 

Learning Objectives: 

• To use a spreadsheet to model a real-life situation. 

Success Criteria: 

• Pupils can understand how a spreadsheet can be used to plan an event. 
• Pupils understand the advantages of using formulae when data is subject to change 
• Pupils have modelled a real-life situation using a spreadsheet. 

Resources: 

• Example workbooks as used previously.  The spreadsheet contains an example recipe, you 
could add variety by using additional recipes for pupils to work in small groups to plan e.g. 
some pupils could work with an egg or milk free recipe to cater for those with allergies, some 
could plan chocolate cupcakes or different decorations such as fruit. They could even design 
their cupcakes beforehand and research their own recipes to make the lesson more relevant to 
real life and combine with design and technology learning objectives. The spreadsheet uses 
example prices, but you might want to show pupils how to look up real prices for their local 
supermarket. (see step 12) 

Activities: 

1. Explain that in this lesson, pupils will be planning for a cake sale and using spreadsheet to help 
them with this. 

2. The tasks for today are: 
• Using a recipe to plan what ingredients to buy so there are enough cakes for everyone. 
• Using the spreadsheet to plan how much we should sell the cakes for to maximise the profit 

made. 
3. Show the pupils the recipe, this makes 24 cupcakes: enough for 24 people. 

• We want everyone in the school to be able to buy a cupcake and some parents and some 
staff. 

• We do not want too many cupcakes because they will go stale and get wasted. 
• Not all children will buy a cupcake and not all parents or staff. 
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4. Look at the Lesson 7 spreadsheet. It has been left unformatted for pupils to format as they 
wish if they have time after filling the data in. This contains three tables: Recipe table, 
Supermarket costs table and Calculations table. Identify these three tables. 

5. The left-hand box contains data about the recipe and calculates a per cake quantity of 
ingredients. 

6. Decide as a class, a sensible number of cupcakes to make for your school and use this figure 
in place of the example figure used in cell C3. 

7. Direct pupil attention to cell B4. It looks like the text does not fit. The same is true of cell G5. 

8. One solution here is to make the cell width bigger. But look at the other cells in column B, they 
all fit their text. A better solution might be something called Wrap text. This makes another 
row for text in the cell without using a different cell, the text then overflows onto two lines. To 
do this, click in cell B4 then on Format in the menu bar. 

9. Select Text wrapping → Wrap (or the icon). On the tablet app look for the icon. 
10. Ask pupils to check how many cakes the recipe will make and suggest how to use a 

spreadsheet to calculate how many times they need to multiply the recipe quantities to make 
the correct number of cakes? Once you have worked this out as a class, put this figure in cell 
C4 

11. Pupils should start by filling in the quantity of ingredients they need for 24 cakes by looking at 
the recipe. In cells C7:C13. The salt and food colouring are separated from the other 
ingredients as only a very small quantity is used, and we can assume that one packet will be 
enough. The cupcake cases will also need to be calculated individually as they come in packs 
with a certain number in each pack. 

12. They should then use a formula to work out the totals in this table (cells D7:D13. Their 
formula will need to multiply the number for 24 cakes by the multiple decided upon in step 9. 

13. Now we know the quantities required, we need to find out how much it will cost to buy them. 
Look up the prices online at a supermarket website or use the example prices in the Example 
supermarket costs table. When looking up prices, remind pupils to use sensible quantities. For 
example, it might be better value to buy big packs of ingredients. Some websites will list 
prices per 100g for items so pupils can compare. Pupils can list the prices in the costs table 
instead of the example ones. 

14. The level of realism you wish to introduce will come down to the pupils’ ability and time 
available. For example, if they need 750g flour, should they buy a 1kg pack or a 500g pack 



Purple Mash Computing Scheme of Work – Unit 6.9 Spreadsheets - – Lesson 7 
With Google Sheets 

Need more support? Contact us:  

Tel: +44(0)208 203 1781 | Email: support@2simple.com | Twitter: @2simplesoftware 

38 

plus a 250g pack? Which is better value? These questions will be too complex for many, but 
some children can be challenged with this. 

15. Prices can be formatted as currency for clear display in cells C20:C35 and other places where 
there are currency amounts. Select the cells and then the Format menu → Number. 

16. Pupils should then use the calculations table to record how many of each thing to buy and its 
unit cost in columns K and L. They should not copy the prices from the price list to do this. 
They should use a formula to carry over the value. To do this, click in the cell where the price 
should go and then type in the formula =<cell reference from the price list>. For example, if 
cell C20 contains the cost of 250g of butter, this cost might then be required in cell L5. Type 
=C20 in cell L5 and the cost will be displayed. See whether pupils can work out an advantage 
of doing this? If not, pose the scenario that the supermarket reduced (or increased) their prices 
before the class have ordered them. How many places would they need to change in the 
spreadsheet if they had used a formula vs typing in the costs again? 

17. Remind pupils that they can use the spreadsheet to do calculations to work out how much to 
get of the different ingredients e.g. 1 tablespoon of milk equals 15ml, they will need to do a 
calculation to work out how many bottles they need. They will need to calculate how many 
packs of cupcake cases to get. 

18. They should add a total column in column M and use formulae to calculate the total for each 
ingredient. 

19. They should then use the SUM function to calculate the grand total  
20. The last step is to look at the questions in column N. In cell 05, use the same method as in 

step 15 to transfer the total cost. 
21. In cell O6, insert a formula that will divide the total cost cell by the cell that has the quantity 

(cell C4). What does this calculate? 
22. Decide upon an appropriate amount to charge per cupcake and put this in cell O9. 
23. Work out the profit if all cupcakes are sold and put this in cell O11. Pupils should try to use a 

formula to calculate this. 
24. Once spreadsheets are complete, you could change the scenario for example, say that milk 

has increased by 10% and see how easily I spreadsheet can deal with the changing cost if 
you have used formulae. Other changes could be different quantity required therefore 
changing the numbers in cell C3 and C4. 
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Lesson 8 Using a spreadsheet to solve 
problems 

Learning Objectives: 

• To apply spreadsheet skills to solving problems. 

Success Criteria: 

• To apply all new spreadsheet skills to solving problems and presenting data. 

• To explore printing spreadsheets. 

Resources: 

• Workbooks as previous lessons. 

Activities: 

1. Explain that in today’s lesson, pupils will be using what they have learnt to solve some 
problems using a spreadsheet. 

2. Open the example sheet for this lesson and show how it is structured into sections with 
activities and questions to answer. 

3. Suggest that pupils can refer to the earlier sheets to remind themselves how to do things. 
4. There are also things built into Sheets to help you. Click on Help in the menu bar and there are 

two options here. Either type something in the searchbar or click on Sheets Help. 
5. Sometimes, when you hover over an icon, it will give you a tool tip which summarises what 

the button does. 
6. Give pupils time to complete the problems. Not all pupils will finish all of them. If pupils are 

using the online or app versions, there will be some tasks that cannot be completed. 
7. Discuss the answers. 
8. Ask what you would do if you created a spreadsheet that you wanted to display somewhere? 

You would print it. 
9. Printing a spreadsheet is a little different from printing a document because often, you will 

want to print a section of it or, you will want a table all printed on one page. 
10. Open sheet Lesson 8 – printing. Ask the class how they think they would print this? 
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11. Click on File→ Print. On tablets, the printing options are much more limited; click on the three 
dots then Share and export → Print. 
12. On a PC you will see a preview. What the preview 
looks like might depending upon your machine settings, but 
it is likely to be something like this: 
13. This does not show the full timetable. 
14. Click on the CANCEL button on the top right. 
15. Select all the cells from A1:I14. 
16. Click File→Print. 
17. This time look at the Settings and select Print 
Selection from the first drop-down list.  

18. Change the orientation to landscape.  

19. The preview should now show more of the timetable but possibly not all of it. 
20. In the Scaling drop-down. Choose ‘Fit to page’. 
21. This should display the whole timetable in a useful way to print. 


