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Pre-requisites 

Saving work 

Have a clear idea about where pupils should save their work. The lessons assume that pupils know 
about folders and files on whichever network they are using. If they do not, it might be worth 
spending some time teaching about files and folders and the difference between saving in the 
cloud, saving on the school server or saving on the device itself where any of these methods are 
used within your setting. It would be useful for pupils to know how to create folders so that they 
can organise their files if they have the security rights to do this. These skills are not used much 
within the lesson plans but will be important for pupil’s ongoing work with the files that they 
produce. 

Printing 

Pupils will not be routinely required to print during these lessons though lesson 7 does include 
considerations when printing. So, it is useful to have a connected printer available. 

Typing 

Pupils who cannot type efficiently, will find having to finish all writing\typing frustrating. Finishing 
all the writing\typing is not required to complete the lessons. Pupils might need extra time to 
compete their documents and include all the text that they wish to include. If you want to improve 
pupils’ typing speed, then make use of the Purple Mash Tool 2Type. See here for the User Manual. 

Language 

The Google suite of tools uses American English in its menus. The spelling used within the 
application is used in these plans when referring to menu items and icons. For example, ‘color’ 
rather than ‘colour’. 
 

https://www.purplemash.com/#tab/pm-home/tools/2type2
https://www.purplemash.com/#tab/2type_guide_and_resources
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Medium-Term Plan  
Lesson  Title Success Criteria 

1 Making a document from a 
blank page 

• Pupils know what a word processing tool is for. 
• Pupils will be able to create a word processing 

document, altering the look of the text and 
navigating around the document. 

2 Inserting Images: Considering 
Copyright 

• Pupils know how to add images to a document. 
• Pupils can edit images to reduce their file size. 
• Pupils know the correct way to search for images 

that they are permitted to reuse. 
• Pupils know how to attribute the original artist of 

an image. 

3 Editing Images 
• Pupils can edit their images within Docs to best 

present them alongside text. 
• Pupils understand wrapping of images and text. 

4 Adding the text 
• Pupils can add appropriate text to their document, 

formatting in a suitable way. 
• Pupils can use styles to format a document. 
• Pupils can use bullet points and numbering. 

5 Finishing touches 

• Pupils can add text boxes and shapes. 
• Pupils can use page breaks, headers and footers. 
• Pupils can add hyperlinks to places in the 

document and to an external website. 
• Pupils can add an automated contents page. 

6 Sharing Files 
• Pupils can share their documents with selected 

users. 
• Pupils understand the different permissions when 

sharing in Google docs. 
• Pupils can share using a share link. 



Purple Mash Computing Scheme of Work – Unit 5.8: Word Processing– Medium Term Plan 
(using Google Docs) 

Need more support? Contact us:  

Tel: +44(0)208 203 1781 | Email: support@2simple.com | Twitter: @2simplesoftware 

6 

7 Presenting information using 
tables 

• Pupils can create a vector drawing in their 
document. 

• Pupils can add tables to present information. 
• Pupils can edit properties of tables including 

borders, colours, merging cells, adding and 
removing rows and columns. 

 
8 Writing a letter using a 

template 
• Pupils can use a template and edit it appropriately. 
• Pupils can use the spelling and grammar tools built 

into Google docs. 
• (Optional) Pupils know how to save a document as 

a pdf and the reasons for doing this. 
• (Optional) Pupils know how to print their 

documents and can print ranges of pages. 
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Lesson 1 – Making a document from a 
blank page 

Learning Objectives: 

• To know what a word processing tool is for. 

Success Criteria: 

• Pupils know what a word processing tool is for. 
• Pupils will be able to create a word processing document, altering the look of the text and 

navigating around the document. 

Resources: 

• See pre-requisites. 

• Formatting Overload story – pupils should have a copy to edit. 

Activities: 

1. Open Docs and look at the front screen, this will vary depending upon the device that you are 
using. The following features might be in different places, but they should all be identifiable. 
Use your version to point out the following sections to pupils: 

A small selection of 
available templates. 

Recent documents 

Options for 
views 
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• Recent documents: show pupils the display options; you can view only those documents 
that you have created or shared documents. You can change the view and sort or search 
for documents. 

• How to open a blank document from this screen, note that there are some templates here 
as well but click on the Template gallery button on the right to see more. Pupils will be 
using templates in future lessons. 

2. Click on the blank document button to open a blank page. 
3. First look at the page layout. Point out the following locations and the words used to describe 

them. If pupils are familiar with the vocabulary, it will make the teaching easier. NB The layout 
and options may differ dependent upon device. 

4. Demonstrate how to get back to Google Docs home using the icon in the top left : 
5. Demonstrate how clicking on any of the menu bar words opens a drop-down menu of 

actions. 
6. Demonstrate how holding your mouse cursor over the icons gives a tooltip to explain what 

the icon does. 

7. Show how to zoom in and out using the zoom control  and clarify that you are just 
enlarging the view and not the writing itself. 

8. Show how to enter a file name by clicking on the file name area at the top of the screen. 
Explain that documents are automatically saved to your Google drive: 
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9. Talk about sensible names for files such as ‘Docs Lesson 1’ even though it does not contain 
any contents yet. Pupils should now open their own Google doc and save their file. 

10. Let us add something to this document now. Click on the page and type your first name and 
surname. Think about how you did this. 
• Did you add capital letters for the first letter of each name? 
• Did you add a space between the words? 

11. Ask pupils to explain how to type capital letters. This varies by device: 
On a device with separate keyboard: Ensure that pupils are not using the Caps Lock key to 
do this: The caps lock key will make all characters that you type, capital letters until you press 
the key again. If you are typing normal sentences you should press one finger down on the 
shift key (usually there are two shift keys on a keyboard, shown with an upward facing arrow) 
On a tablet touchscreen:  Use the shift key, double pressing the shift key will do the 
same as caps lock. 

12. How do you go onto another line to continue typing? Show pupils how to press enter. 
13. Do you need to do this every time you get near the edge of the page like you do when 

writing? Ensure that pupils know that Word will automatically go onto the next line. You only 
need to press enter if you want to start a new block of text. 

14. Introduce the vocabulary ‘cursor’. This is the flashing vertical line that shows your place in a 
document. You can use the arrow keys to move the cursor around. This is very useful when 
editing your text. 

15. Ask pupils to type a paragraph (3 sentences) to introduce themselves. While they are 
working, question them about how you ‘rub out’ when using a word processor, stop the 
pupils to demonstrate the use of the backspace key to delete the character before the cursor 
point and the delete key to delete the character after the cursor point. 

16. Once pupils are ready, they are going to have a play around with formatting their text. 
17. Demonstrate how to select text to edit. There are different ways to do this, instructions below 

are for non-tablet devices (on tablet devices, selection is done by a double press and then 
altering the sliders that appear): 
• Double-clicking on a word will select the whole word. 
• Pressing the mouse button down and dragging will select the text dragged over. 
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• Clicking somewhere and using the arrow keys to get to the start position of the select then 
holding down the shift key and using the arrow keys to get to the end of the selection will 
select text. This is particularly useful for pupils who lack precise mouse skills. 

18. Be careful when you have text selected not to press any key as it will overwrite everything 
you have selected. Demonstrate this to the class with your own text and feign worry. Then 

direct their attention to the undo key  to demonstrate how this works. 
19. Show how you can change fonts and font sizes of selected text using the Font category.  

 
20. Show how to change the paragraph formatting using the icons:  

• left-align 
• centre 
• right-align 
• justify text 
• line spacing 

 
21. At this point, show the help tips that appear when you hover your mouse over one of the 

alignment options e.g.  

 
The part in brackets is called a keyboard shortcut. In the above example, if you select some 

text and then press the Ctrl, Shift and E keys, the text will become centred. 
22. Give pupils time to format their paragraph how they wish. 
23. When they finish, they should add a title to their work for example, ‘All About Me’, this should 

go on a separate line. They should centre the text. 

Use the title to demonstrate how to make titles bold. The other option here is italic, which gets 
used for quotes, and underline. 

24. Show pupils the formatting overload story. Do they like the look of it? Would it be easy to 
read? It is sometimes fun to play around with using lots of different front but if you want your 
documents to be readable, you should add some consistency. As a rule: 

• One font or font family used throughout a single document – switching between lots of 
different fonts is hard to read. 
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• Use underlining sparingly; look at the lines underlined and blue in the text, what do they 
look like? Answer: hyperlinks to a website. The danger with underlining is that it all ends 
up looking like web links. 

• Use bold for titles and key words. 
• DON’T USE ALL CAPITALS, IT LOOKS LIKE YOU ARE SHOUTING AT THE READER. 

25. Pupils could have a copy of this document to format in a more readable way. 
26. It’s useful to know, that if you ever get in a muddle with formatting some text, you can 

highlight it and then click the  button and it will remove all formatting so you can try again. 
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Lesson 2 – Inserting Images: 
Considering Copyright 

Learning Objectives: 

• To add and edit images to a document. 

Success Criteria: 

• Pupils know how to add images to a document. 
• Pupils can edit images to reduce their file size. 
• Pupils know the correct way to search for images that they are permitted to reuse. 
• Pupils know how to attribute the original artist of an image. 

Resources: 

• Copy and Pasting poster. This will be used on the whiteboard or can be printed for pupils. 

Note: Pupils will be using the Internet to search for images. A discussion about this forms part of 
the lesson plan. Ensure that you are clear about any school procedures to take if pupils find any 
inappropriate images. There are sites such as https://pixabay.com/ that provide royalty-free 
images that can be used without considering copyright. However, many pupils will already be 
using Google’s image search to find images to use in their documents, so it is felt important to 
teach them the appropriate way to use such images. 

Activities: 

1. Explain that today, pupils will be starting work on a document that will either explain how to 
look after something such as a pet, a sibling, a prize possession or a visiting alien or the 
document will be about a particular topic. You (the teacher) could specify the topic as 
something that you are studying in class if you wish or leave the choice up to pupils. Pupils 
will be adding to their document in each lesson. 

2. They can have a think about this as we get the page set up, have a think about what you will 
do.  

3. Open a new blank file and click on File in the menu bar. 

https://pixabay.com/
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4. Click on Page setup in the menu, to open the following screen: 
5. Explain the difference between a portrait page and a landscape page and demonstrate how to 

change this using the radio buttons. Pupils can make the choice about what layout they 
would like. 

6. Look at the other options on this screen and discuss what they mean: 

• Some readers might find it easier to read text if the page is not white. For example, some 
readers with dyslexia find a pale blue or pink page easier to read from. The page colour will 
transfer to the printed document and is not just a background colour on screen. 

• Making margins too small can mean that edges are cut off when the document is printed. 
• A4 is the size of a standard sheet of paper used by printers. Discuss other page sizes if you 

wish. 

7. Zoom out using the icon so that you can see the whole page. 
8. As part of this work, pupils will need to copy and paste text. Demonstrate how to do this 

using the poster.  
9. Pupils will need some images for their documents, they can get these from images already 

downloaded on the network (if such images are available) or by searching on the Internet. 
10. Discuss the following aspects of searching on the Internet: 
11. Safe searching: explain how your school network has safety filters in place but that this might 

not be the case at home. What should pupils do if they come across an image that they think 
is inappropriate; refer to your school’s policies for advice on this. What should they do if they 
are upset by anything they see online? 

12. Copyright: explain that many images are not available for you to download and use online. To 
find images that you can use, you need to use the advanced search tools in the search engine. 
This example uses Google images. Demonstrate the process in the following steps. 
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13. Open a page to the Google search engine and type in your keyword (pupils following the 
Computing Scheme of Work will have studied searching in units 2.5 and 4.7). Pupils using 
tablets can search Google in the same way. 

 

14. Click on Settings and then Advanced search. (On a tablet click on the ‘Labeled for Reuse’ text 
then go to step 17). 

15. Scroll down to the Usage rights section: 

16. Select the option ‘Creative Commons licences’ and click the Advanced search button. The 
results will all be images that you could download and use in your flyer. Wikimedia commons 
files are often good ones to look for. The following example uses an image from Wikimedia 
commons other locations will have similar but different procedures for download. *see step 20 for 

alternatives. 
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17. When you find an image that you like, click on it (you might have to click twice) to be taken to 
a screen where you can download and also see the copyright information. On a tablet, look for 
text below the image that says ‘File: xxxxx’ and click on it. 

18. On a PC or laptop, click the Download button and you will see the Attribution details, you 
should copy this into your document so that the original artist is credited with the image. 
See the example on the image above, the attribution is in small text below the image. 

On a tablet, try to make a note of the author and copy the website address to put both in your 
attribution. To copy the website address, click on the address bar (URL) then select and copy 
the address. NOTE, the method will vary by device and website, so ensure you know the 
procedure for the device that your pupils will be using. Then press on the image and a menu 
should pop-up with the option to ‘Save Image’, this will save to your device. 

19. You can also choose the image size, for your document, a smaller image size will save 
computer memory and load your file more quickly. In general, it is best to use the smallest size 
that will display your image well in the document. 

Ilyusha isakov [CC BY-SA 

(https://creativecommons.org/licenses/by-sa/4.0)] 

https://creativecommons.org/licenses/by-sa/4.0
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20. **Sometimes, clicking on an image will take you straight to the website that the image is on, 
there might still be an attribution that you can copy. Where possible, use an attribution when 
you use someone else’s image. To download the image, you can right-click on it and choose 

Save Image As: 
21. Ensure that pupils know where they are saving the images to so that they can find them to 

insert into documents. Pupils should then find 5 images to use and download them. 
22. It is worth considering image file size once pupils have downloaded their images. The 

following steps show how to view the image size and how to reduce it on a Windows  PC or 
laptop. 

23. The following screenshot shows several large image files. Pupils can get the same view of 
their images by opening Explorer, navigating to the folder, clicking on ‘View’ and then 

‘Details’: 
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24. The file size is displayed in the right most column. Double clicking on the file will open it in the 
Photos app. From here, click on the three dots in the top right-hand corner. Then click Resize: 

©Rebecca Summer, 2020 

25. At the next screen choose M or L. Then give the file a name, this can be the same as the 
original plus the word ‘small’. Then compare the two versions: 

26. Give pupils time to resize their images then bring the class back together. 

27. To insert an image into a document you can use the Insert menu (or the icon ). 
28. Have a look at the options in the Insert menu: 
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29. Discuss these if you wish. Can pupils see which icon to use to insert a picture?  
30. Demonstrate how to insert an image. Show pupils how to navigate to the location where their 

images are stored. 
31. Pupils should insert their images into their document; this will probably cause the document 

to have several pages and images might be too big or need cropping. Tell pupils that they will 
be doing this next lesson and for now, should just aim to insert the images and save their 
document. 
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Lesson 3 – Editing Images  

Learning Objectives: 

• To know how to use word wrap with images and text. 

Success Criteria: 

• Pupils can edit their images within Docs to best present them alongside text. 
• Pupils understand wrapping of images and text. 

Resources: 

• Copy and Pasting Poster. This will be used on the whiteboard. 

• Example file with five large, unformatted images inserted (this should replicate the pupils’ 
outcome from the last lesson. 

• Wrapping poster for use on the whiteboard. 

Activities: 

1. Open the example file and remind pupils that the files that they started last lesson will look like 
this. 

2. Explain that sometimes you might want to edit an inserted image. First let us find out how to 
change the size and trim an image. 

3. Zoom out so that the whole page can be seen (see last lesson for details) . 
4. Click on the first image and point out the ‘handles’ that appear on the image edges. This 

indicates that the image is selected for editing. Notice that the icon bar has changed to include 
some image editing icons: 
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5. Firstly, use the rotation handle to rotate the image to the correct orientation: 

6. Next, look for the Crop image icon  and click on it. Notice how the handles now have 

additional black frame indicators: 
©Rebecca Summer, 2020 
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7. Crop the image by dragging these inwards so that the boy and the background are cropped 
out. Then click elsewhere on the page to perform the crop: 

©Rebecca Summer, 2020 
8. Show pupils how to then resize the image if they wish, using the handles. 
9. Now, ask pupils to imagine that they wanted this image as a central image in their flyer. They 

might try to drag it to the centre of the page. Try to do this and you will probably find that you 
cannot: On a tablet, you might be able to do this as the tablet can alter settings automatically. 
Explain that this is to do with a feature called ‘wrapping’. 

10. Click on the image again and look in the symbols below the image:  

11. Hover over them to see what the tooltips say. 
12. Click on the three vertical dots the All image options. This is also available in the menu bar. 
13. A screen appears on the right-hand side with a variety of options associated with image 

editing. 
14. Click on the arrow to open the Text Wrapping options:  

15. The little illustrations on the choices show how the image will be arranged relative to the text 
around it (and other images). Clicking on an option such as Wrap text will enable you to set 
other options such as the margins from the text and whether to wrap on both sides. 

16. Use the Wrapping poster to illustrate some of these. Go through each of these options. 
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17. Another thing to note is how the image is anchored to the page. This can be found in the 
Position option dropdown. The choices are Move with Text and Fix Position on Page. Pupils 

will need to experiment with this to achieve the desired effect.  
18. The main point to make, is that things do not re-arrange themselves, it is often something to 

do with the wrapping settings so being familiar with them is useful. Remind pupils about the 
undo button to use if things go very wrong and they want to get them back to how they 
previously were. As they add more text and formatting to their document, the images might 
move unexpectedly and need to be moved again. 

19. Another option when inserting images, that can be found in the Image options, is Recolor. 
Click on one of the example images in your file. Then on the arrows to reveal the effect 
options: 

20. The final option to consider is Adjustments. These also alter the look of the image: 
Use one of the example images to show the effect of altering the slider for each of these 
options. Show pupils the Reset button that will remove the effects and go back to the original 
image. 
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21. You can also use the icons in the top menu bar to add a border to the image. Click on the 
image and then choose the options: 

Border colour Border thickness Border style 

   

22. Emphasise the need to make any image formatting relevant to the overall purpose of the 
document. It is fun to get carried away with effects, but you will never finish the document 
this way. 

23. Give pupils time to edit their images and decide how to format them. They have not entered 
any text yet and when there is text, they might wish to change the formatting but for now, 
they have an opportunity to familiarise themselves with the tools for this. 
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Lesson 4 – Adding the text 

Learning Objectives: 

• To change the look of text within a document. 

Success Criteria: 

• Pupils can add appropriate text to their document, formatting in a suitable way. 
• Pupils can use styles to format a document. 
• Pupils can use bullet points and numbering. 

Resources: 

• Example file  

Activities: 

1. Pupils’ files should now have some nicely formatted images but no text. Explain that today, 
they will be adding the text. 

2. Direct pupils’ attention to the Styles icon in the toolbar: 

3.   Explain that it is useful to use styles when creating a document for several reasons: 

• All headings, lists and text will be formatted consistently making your document easier to 
read. 

• To format text, you simply select it and then choose the style, you will not have to choose 
the size, underlining and paragraph options each time. 

• If you want to change the style of something e.g. you want the main text to be a different 
font or size, you can change it once in the style set and it will update your document. 

• You will be able to use the built-in navigation tool to find what you want in your document. 
You can demonstrate this by opening the lesson example file and clicking the icon on the 
left-hand side: 

 This will show the outline for the document. You can click to jump to a place in 
the document. 
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• You can automatically create a contents page for the document.  

4. To make the heading a certain style, firstly, format one of the headings using the font and 
colour tools. 

5. Next, highlight that text. 
6. Click on the Styles dropdown arrow and put your mouse over the type of heading that you 

want the text to be (the example below is going to be the main title). 

7. Click ‘Update ‘xxx’ to match. Where ‘xxx’ is the type of heading. 
8. Ask pupils to decide upon headings and sub-headings for their document. They should then 

style these. 
9. They should and just the first sentence of each section for now; like the example. Images can 

be placed in the appropriate section with appropriate text wrapping. Pupils should not worry 
too much about spelling for now as they can use any spelling errors when it comes to this part 
of the lesson. They must be able to read what they have written though. 

10. Once pupils have styled their document, they should check that the document outline looks as 
they expect. 

11. Ask pupils to think about a place in the text where they could put a list of things. The example 
contains a list of things needed to keep a guinea pig. Discuss the use of bullet points for un-
ordered lists and demonstrate how to bullet a list by selecting the list and using the bullet icon 

. 
12. Show that clicking on the small arrow gives other options for the design of the bullet points.  
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13. Ask pupils to think about a place in the text where they could put an ordered list of things. 
The example contains instructions on cleaning out a guinea pig cage. Demonstrate how to 

number a list by selecting the text and clicking the  icon. Again, you can use the small 
arrow to select the format: 

14. Pupils should use the rest of the lesson to further refine their document by adding bullets 
and lists and completing the text. They could add additional images where necessary. 
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Lesson 5 – Finishing touches 

Learning Objectives: 

• To add features to a document to enhance its look and usability. 

Success Criteria: 

• Pupils can add text boxes and shapes. 
• Pupils can use page breaks, headers and footers. 
• Pupils can add hyperlinks to places in the document and to an external website. 
• Pupils can add an automated contents page. 

Resources: 

• Example file. 

Activities: 

1. Open the example file, this can be used to demonstrate some finishing touches that pupils 
can make to their documents. 

2. Textboxes for captions 

Pupils might want to add some text to their images to explain what the image shows. This is 
called a caption.  
• To add a caption, you can use a textbox. Textboxes can be used to add some text out of 

the usual flow of the text in the rest of the document. To insert a textbox, use the Insert 
tab and find the Drawing Option. 

• Click ‘New’ 

• This opens a drawing screen. You can add a textbox by clicking the  icon. 
• Then drag a rectangle shape onto the drawing area. 
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• You can then type in the box and format it like you would any text. You can also alter the 
fill colour and border of a textbox using the icon buttons available. Remember that the 
main thing is that formatting should enhance the appeal and readability, not detract from 
it. 

• Click Save and Close to add the drawing to the document. You might need to change the 
wrap settings and drag it to the desired place in the document. 

3. Shapes 

In the Insert/Drawing menu there is also a shapes icon . 
• Shapes are useful in documents for a variety of purposes. You might want to put a shape 

under an image to highlight it, you can use arrow shapes for instructional writing. 
• You can add textboxes inside shapes such as call outs to add interest to your text. 
• Shapes can be formatted like textboxes, they also have blue handles that can be used to 

adjust the shape, a blue turning circle to rotate the shape and (some shapes only) yellow 
adjustment diamond to adjust the shape. Drag these to see what they do. 

• You can also right-click on a shape and then on the Change Shape option: This gives you a 
choice to change the shape if you wish. 

• To remove a shape, click on it and then press the delete key. 
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4. Layering 
If you want to put shapes and textboxes overlapped or on top of each other. You need to 
think about the document in layers and use the layering controls to get the elements in the 
correct order. 
• Firstly, add more than one object to a drawing. The example has a star, an arrow and a 

photo (you cannot see the photo as it is under the other objects). 

• Right-click on an object that is in front when it should be behind another object. 
• In the menu, select Order, and then choose the appropriate option. In this case ‘Send to 

back’. 

5. Page breaks, section breaks, headers and footers 

You might want to organise your document so that at some points the flow moves to the 
next page. For example, if you have added a title and then there is no space left on the 
page for the text that goes with it. Or you add a line of text and you want an image with it 
but there is no space left on the current page. In this case, you can add a page break.  
• Do this by clicking Insert → Break 
This is better than just pressing the enter key 
to move onto the next page because if you 
change things earlier on in your document 
you could end up with a big blank space 
within a page whereas if you use page break, 
the break will still occur where you put it. 
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Something to consider when putting in breaks is whether to use section breaks rather than 
page breaks. A section break allows you to format each section differently, say you wanted 
some pages in landscape and others in portrait, then you could do this using section 
breaks. Section break are also useful when you are using headers and footers. 
• Open the example document and ensure that you are on page 1. 
• Click Insert → Headers & Footers and choose Header. 
• This will put a header on every page with space for text. If you have sections, you can 

have different headers for each section. Enter the following: 

• Click on the page and you will see how the header looks on each page. 
Another useful thing in a long document is page numbers. 
• Click Insert → Page numbers. 
• Choose the location that you want the numbers to appear. 

6. Give pupils a short time to try out these four things. You might want to put a list on the 
board. Some pupils will not be able to create headers and footers but an awareness that 
they exist is useful. 
• Textboxes for captions 
• Insert one shape 
• Add page or section breaks 
• Add headers and page numbers. 

7. Bring the class back together and ask pupils to think of anywhere in their document that 
they could link to another place in the document. In the example you could insert a link from 
Fresh vegetables and fruit in the Consumables list to the section about what to feed your 
guinea pig. This is known as a hyperlink. Use this example to show pupils how to put a link 
into their document. 

8. Click at the start of the heading, ‘What to feed guinea pigs’. 
9. Click Insert → Bookmark 
10. Go back to the list of consumables and add some text to be the link text e.g. ‘Click here to 

find out more about what to feed your guinea pig’. 
11. Select the text. 
12. Click on the Link icon . 
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13. Look for where Bookmarks are listed (you might need 
to click on the small triangle)  

14. Click on ‘What to feed Guinea Pigs’ and ‘Apply’. 
 
 
 

15. Ask pupils to do two things now: 
a. Add a hyperlink to another place within their document 
b. Look online for a suitable website to link to on their chosen topic. You might wish to 

review how to tell if a website is a reliable source of information. 
16. When most pupils are ready, stop the class and ask them to move to the end of their 

document. A quick way to do this is to press the keys Ctrl + End. 
17. Type the sentence ‘For more information you might want to look at this website.’ 
18. Go to the website and copy the URL (select the address and press Ctrl + C). 
19. Go back to your document, select the sentence and turn it into a Link but this time paste the 

website URL into the Link box instead of using a bookmark. Then click ‘Apply’. 

20. You can test your hyperlink clicking on the link. 
21. The final thing to do now is to add a contents page. This should be easy because the 

document is already organised into headings. Go to the beginning of the document by 
pressing the CTRL Home keys. 

22.  Insert a section break (Insert, Breaks, Section break (next page). This should add a new 
page at the beginning of the document. 

23. Click at the beginning of the document again and then Insert → Table of Contents. 
24. Choose a format; either page numbers (good for a printed document) or links (good for an 

online document). 
25. You can update this at any time, say if you change the document, by 

clicking on update table in the top left of the table. 
26. Pupils should add a Contents page and use any most of the further time to enhance their 

document and add text. Make sure they save all work.
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Lesson 6 – Sharing Files 

Learning Objectives: 

• To use the sharing capabilities in Google docs. 

Success Criteria: 

• Pupils can share their documents with selected users. 
• Pupils understand the different permissions when sharing in Google docs. 
• Pupils can share using a share link. 

Resources: 

• Pupils’ files created in previous sessions. 
• Example File for this lesson 
• Note: Sharing capabilities will differ depending upon the way that you use Google docs in 

your setting e.g. through Google Classroom or otherwise.  Explore the sharing capabilities 
for your own setting. 

Activities: 

1. Explain that using Google docs allows you to share and collaborate in your documents. 
2. Show pupils the example file; look at the first couple of questions only and exaplain that you 

are going to demonstrate how to share it so that everyone can contribute their ideas. 
3. Hover over the Sharing button in the top right. This demonstrates how the document is 

currently shared. 
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4. Click on the button to open the sharing options. Initially, you are given a tip about sharing 
restrictions settings. 

5. When you click in the ‘Add people and groups’ box it might pop up with the email 
addresses of those in your class or your contacts and you can click on them. Alternatively 
enter the email addresses of the people that you want to share the document with. 

6. Ticking the tickbox will send that person an emal to tell them that you have shared the 
document. You can type the contents of the email in the box. 

7. Click on the ‘Editor’ drop-down box and you will have three options about how to share the 
document. 

8. Go through each of these and set it to ‘Commenter’. Then click ‘Share/Send’ 
• Viewer: You can view the document but not change it. Depending upon the setting 

set by clicking , you can set whether they can download, print or copy the document. 
• Commenter: You can make comments on the document. Depending upon the 

setting set by clicking , you can set whether they can download, print or copy the 
document. 
• Editor: You can change the document. Depending upon the setting set by clicking 

, you can set whether they can change the sharing permissions of your document. 
9. Ask pupils to login to Google docs and go to the Google docs homepage. 

Your name 
You email address 

Person’s email 
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10. They should be able to find the document by looking at the bottom half of the screen and 
changing the drop-down to ‘Not owned by me’: 

11. Ensure that you are in editing mode (top-right): 

12. Ask 5 pupils to open the document and type their name under the heading. You should see 
all of their names appearing on the document as comments. Each person has a different 
colour. You can click on the Open Comment History  icon in the top right to see who has 
commented what and when. 

13. Explain that as the pupils were set up as commenters not editors, you are able to accept or 
reject their comments. Accepted comments will appear in the document. Rejected 
comments will be removed. 

14. Reject all of the comments by clicking on the cross next to the comment. They should 
disappear from all of the screens. 

15. Explain that you are going to change all of the pupils to Editors and you would like them to 
open the document again and try to answer the questions. They don’t need to type an 
answer if someone else has typed the answer they would have selected, they could just 
type I agree or think of a different suggestion and go on to the next question. 

16. Click on the Share button, use the dropdown box next to pupils’ names to set them to 
Editors but change the permissions so editors cannnot change the permissions. You might 
want to talk about why you are doing this. The save the settings and allow upils to get to 
work. 

17. Give pupils time to answer the majority of questions and then review the answers. This 
should help to give pupils guidance in completing the next activity. 

18. Direct attention to the ability to revert to a previous version of the document, you might 
want to do this if you share with someone who makes changes that you don’t like. To do 
this, look in the file menu: 
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19. When you click ‘See version history’, you can view the previous versions of the document 

and click the button if you want to go back to a previous version. 
20. Pupils should now share their own document with another pupil. You may wish to 

designate who shares with whom or allow pupils to choose. 
21. Allow pupils time to edit another’s document with the aim of improving it. 
22. Bring the class back together and ask poupils how they feel about the changes made. 
23. Explain that you can also share documents more publicly or if you don’t know the email 

address of the people thhat you want to share with. 
24. To do this you create a link by clicking on the Sharing button and look at the bottom section 

of the screen: 

25. You can click on ‘copy link’ to copy the link to your device then you could paste it 
somewhere else. 

26. Click on the ‘Change to anyone with the link’ option and explore the meaning of the choices 
that you are then given; these mirror those given when sharing via email. 

27. In Purple Mash, there are several tools which will allow you to add a link. For example, 
2Blog posts, the Launch command in 2Code and buttons and sprites within 2Create a Story 
Adventure mode. 
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28. If you have time, pupils could try making a Purple Mash blog, game or story that contains a 
link to their document. 
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Lesson 7 - Presenting information 
using tables 

Learning Objectives: 

• To use tables within Google Docs to present information. 

Success Criteria: 

• Pupils can create a vector drawing in their document. 
• Pupils can add tables to present information. 
• Pupils can edit properties of tables including borders, colours, merging cells, adding and 

removing rows and columns. 

Resources: 

• Example file for lesson 7, each pupil will need a copy of this document that they can edit. 
• Pupil photos or avatars; either access to a webcam to take a photo or use the Purple Mash 

avatars. To download the Purple Mash avatar, click on the small avatar at the top right of the 
screen after logging into Purple Mash. This opens the avatar creator. Click on the Download 
button to save an image file to the device. 

• Timetable task list: This can be displayed on the board or printed for pupil reference. 

Activities: 

1. Explain that today, pupils will have another opportunity to explore the drawing elements in 
Google docs and they will be learning about tables. They will do this whilst creating a 
document for a new (imaginary) school where all the subjects have been replaced by things 
that they probably do not get to do too often at their current school. The example document 
will become the handbook for the new school. It has some placeholders and as they progress 
through the lesson, pupils will be editing these. 

2. Open the document on the board, note the logo on the first page: Pupils will be designing 
their own logo for their school. Scroll down to the second page. Note that the document is 
landscape and contains a timetable. Have a look at some of the lessons. Pupils will have the 
opportunity to edit these so if they have always fancied attending a school of Dance, 
Computer programming or even Wizardry and Witchcraft, they will be able to adapt what is 
there. 
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3. First, pupils need to be thinking of a name for their new school. They will be typing this is as 
part of a google drawing to create a school logo. 

4. In lesson 5, steps 2-4, pupils were introduced to shapes and textboxes. This is an opportunity 
to get more creative by designing a logo. You might wish to review how to insert and layer 
shapes and textboxes. 

5. The example logo can be used to demonstrate and can then be edited or deleted by pupils. 
6. Click on the logo, and then the Edit option that appears below it. Explain that this logo is made 

up of several overlapping elements. You can click on each one separately to edit it. For 
example, click on the shield shape and resize it. Remind pupils about the undo button in case 

they make unintended changes . 
7. Right-click on the shield and bring the shape to the front using the Order menu. Does this 

mean that the text has now been deleted? 
8. Answer: No. Explain that this is called a vector drawing program. Can they contrast this 

with using a tool such a 2Paint or other painting programs? For example, in 2Paint if you 
add a circle on top of another shape, you cannot then individually edit the properties of each 
shape. 

9. Click on one of the text areas and remind pupils how to change the text and font or colour 
options. 

10. Draw pupils’ attention to the image of the cooking pot on the logo. Explain that you can 

search for images directly from the drawing panel by clicking the icon. 
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11. From here, click on Search and take note of the copyright notice under the search bar. This 

means that the images can be used in your work. Once you search, you can refine the 
choices: 

12. Logos usually use Clipart rather than photos. You can filter using a colour that matches the 
logo. When you have decided uopn an image, click select, and the image will be imported. 
You can then resize and crop it. 

13. Give children some time to get creative with the school logo. 
14. The next task is to add a table and fill in your personal details. 

Demonstrate how to insert a table.  This is done from the 
Insert tab. Drag the mouse over the diagram at the top to 
select the number of rows and columns. Insert a table with 6 
rows and 3 columns.  

15. Display the following table and ask pupils to copy the 
questions and fill in the answers in the second column. Note: feel free to use different 
questions, the intention is to be different from the usual birthday, favourite subject and not 

reveal actual personal details (DOB, address etc) in case work is to be displayed or shared 
at any point. 

16. Once tables are filled in, demonstrate how to select/highlight parts of the table such as 
rows or columns. 

17. You can then edit aspects such as the fill colours, borders and line styles in the top icon bar: 

.  These icons will appear when you click anywhere inside a table. You 
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can also use the small grey arrow that pops up to decide where the borders should be, but 

this will take a bit of experimentation . 
18. The third column of the table will be used for an image of the person (see resources 

section). Point out that their image will not fit into one cell but would be better using all the 
cells. The way to do this is to use something called merging cells. You can do this to any 
cells that are next to each other in columns or rows. 

19. Select the cells to be merged. In this case, the cells of the third column. 
Right-click (or click on the Format→Table, menu) and look at the menu that 
pops up. There are other choices that will be useful later such as inserting 
rows and columns. 

20. Find the Merge cells option and click on it. Review the effect. You can insert 
your image and then resize it, so the table still looks good.  

21. Scroll down to look at the timetable. Explain that pupils will be improving this timetable and 
that you will be giving them a list of tasks to complete. This will include the opportunity to 
change the names of the lessons to fit their own theme. Explain that you are going to show 
them the skills needed to complete some of the tasks. 

22. Inserting columns or rows 
One of the tasks will be to add an extra lesson between what is currently labelled lesson 4 
and 5 (note there is an error in the naming that pupils will be correcting). 
To do this, select/highlight the column for lesson 5. Right-click or click on the 
Format→Table, menu. Click Insert column left. 

23. Column widths 
You can place your mouse on the border between two columns and the cursor symbol 

should change to  These can be dragged to alter the widths. 
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Another useful tool if you want all columns in a selection to be evenly sized is to select the 
columns and click Format → Table → Distribute columns. You can also do this for rows. 

24. Show pupils the Timetable Task list. They should use the lesson to complete as many of the 
tasks as they can. 
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Lesson 8 Writing a letter using a 
template 

Learning Objectives: 

• To introduce pupils to templates and the pdf format. 

Success Criteria: 

• Pupils can use a template and edit it appropriately. 
• Pupils can use the spelling and grammar tools built into Google docs. 
• (Optional)Pupils know how to save a document as a pdf and the reasons for doing this. 
• (Optional) Pupils know how to print their documents and can print ranges of pages. 

Resources: 

• Poorly written example letter. Each pupil will need a copy of this document that they can copy 
and paste from. 

The approach taken here is to focus on the formatting and Word tools rather than the skill of 
composing a letter, but this lesson could be linked to letter writing in another subject if desired. 
If you wish pupils to compose their own letters, this could be done instead. 

• Copy and Pasting poster. Pupils used this in lesson 2, it could be used on the whiteboard or 
can be printed for pupils as a reminder. 

Activities: 

1. Open Google Docs and look at the templates that appear on the first screen, click on Template 
gallery so see further available templates. Slowly scroll down and ask pupils to identify the 
different sections that the templates are organised into. 

2. Explain that it can sometimes be useful to use a template for a document, it might add some 
interesting formatting and the layout will be provided for you. However, it might not include 
everything that you want your document to include so you will need to add things and delete 
others to get the document looking how you like. 

3. Today, pupils are going to be editing a formal letter of complaint. Can they find any suitable 
templates for a letter? Help pupils locate a good template choice. Once chosen, open this 
template.  Options in the following steps might vary depending upon the specific template and 
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will need to be adapted as required. The Template used in the examples below is called 
Business letter Geometric. 

4. Direct pupils to look at their chosen template, within the document will usually be ideas for 
how to customise it. The example sets out the address for the author and the recipient of the 
letter, and it has a suggested greeting. To use a template, you overwrite the example text. 

5. Show pupils the Poorly written example letter. This contains the information that you need 
to put into your letter. If you wish pupils to compose their own letters, this could be done 
instead. The approach taken here is to focus on the formatting and tools rather than the skill 
of composing a letter, but this lesson could be linked to letter writing in another subject if 
desired. 

6. Initially, it is almost impossible to read the letter. This is because the line spacing has been 
set to smaller than 1 line. Remind pupils how to select all the text: Go to the start of the 

document and press Ctrl + Shift + End (desktop). Tablet options vary by device. Then look 
for the line spacing icon: 

7. Choose a better line spacing. Explain that pupils might want the addresses to be more 
closely spaced than the bulk of the letter. 
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8. Remind pupils how to copy and paste from one document to another by whichever method 
relates to the device that pupils are using in class. 

9. Pupils should copy and paste parts of the letter to the correct places in their template. 
10. Once they have done this, demonstrate how to perform a spelling and grammar check on 

the document: 
11. Firstly, click on File → Language and check that the correct language is selected. 
12. Pupils might have noticed red lines (spellings) or blue lines (grammar) appearing under text. 

There are different ways to spell check: 
a. Right-click on an underlined word and Word might suggest the correct spelling or 

grammar correction which you can then click. It is worth having a brief look at the 

other options shown, as well. 

b. Check the whole document by clicking on the spelling and grammar check icon: . 
13. A screen will open:  

You can then accept or reject the suggestion. Clicking on the three vertical dots, opens an 

additional menu of choices: 
14. Pupils should improve this poorly written letter using the following methods: 

• Spell and grammar check 
• Identify words that could be improved using the built-in dictionary. To access this, select a 

word and right-click on it then on ‘Define…’ or select the word and click Tools →Dictionary. 
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• As well as a definition for the word, there will often be examples of words with a similar 
meaning; look for the words in blue text. 

• Greetings: How should the writer address the person they are writing to in a formal letter? 
How should they sign off correctly? 

15. Use the Sharing facility to display good examples of the letter on the board and review the 
changes that were most effective. 

16. (Optional saving as pdf activity) Bring the class back together and ask them if they have ever 
had a situation where they open a document and all the formatting seems all over the place? 
Sometimes, when you are sent a document that has been formatted using a different program 
or version this can happen. You might want your document to stay looking how it is especially 
if it contains images, captions or tables. 

17. Can they think of any other situations where they would not want their document changed? 
Pupils might think about copyright and plagiarism. If not, bring them onto this topic. 

18. Explain that you can often save documents as pdfs, this means that another person will see it 
in the format that you intended, and they will not easily be able to edit it. 

19. To do this, click on File → Download. 
20. Choose PDF document. The document will save to their device in pdf format. On a desktop it 

may appear in the download bar at the bottom and it can be clicked on to view. Other devices 
will save differently, so check what will happen with the devices that you use in class. 

21. Have a look at the pdf that is created and see how it is not editable like a docs document is. 
22. (Optional Printing activity) Printing will vary depending upon your school set up and the type 

of printer that you have. Therefore, specific steps are not given for this activity. You should 
aim to demonstrate how to do the following in your setting and talk about how pupils should 
be able to do similar on home printers as well. 

• Choosing the printer. 
• Printing a selection of pages rather than the full document. 
• Printing different sizes. 
• Printing double-sided 
• Printing more than one page on each sheet of paper. 

 


